The support forum

How to suppress "missed backup" alerts

Apr 10, 2018

Overview


When a backup job is set to run periodically, the program will flag the job with an error if the job misses a scheduled run. This happens in three cases:

    1. The program was running, the job was due, but either or both of
         job's devices weren't present.

    2. The program was not running, when the job was due. In this case
         the error is logged on program's launch.

    3. The computer was asleep, when the job was due. In this case the
         error is logged when the machine is woken up.

It is possible to suppress or delay error reporting in all three cases.

Apr 10, 2018

Case 1 - Missing devices


The backup engine can delay reporting an error for a configured amount of time, which is referred to as a "grace period". The grace period is started with the first "missed backup" failure and it is reset with the first successful backup.

This option is controlled with the following entry in job's settings.ini:

        conf.missed_run.grace_period

By default it is set to 0:0, which stands for "disabled". The value of this entry is a "time interval", so it can be set to "1 hour", "3 days", etc.

* See https://bvckup2.com/support/forum/topic/933 for how to find and edit the settings.ini file.

Apr 10, 2018

Case 2 - Program wasn't running


It's possible to suppress the "missed backup" error using the following entry in settings.ini file for the job:

        conf.missed_run.register_on_launch   0

By default it will be set to 1, which stands to "enabled".

* See https://bvckup2.com/support/forum/topic/933 for how to find and edit the settings.ini file.

Apr 10, 2018

Case 3 - Computer was asleep


It's possible to suppress the "missed backup" error using the following entry in settings.ini file for the job:

        conf.missed_run.register_on_wakeup   0

By default it will be set to 1, which stands to "enabled".

* See https://bvckup2.com/support/forum/topic/933 for how to find and edit the settings.ini file.

Homer712 :

May 02, 2018

Everything was running just fine when I had the setting "when files or folders are modified, in real time", but when I set the backups to run "every 30 minutes" I get failure messages for all backups when the computer has been shut down for a period of time, as overnight and then restarted. Tried the "Case 3" solution above and set the 0.0 to 72.0 thinking that would give me a three day grave period. Does not work, when I relaunch the app, the errors are still there and if I look at the backup *.ini file it's been reset to 0.0, not the 72.0 that I set it to. May the have something to do with the "Start minimized option not working that I posted on before?

Alex Pankratov :

May 03, 2018

set the 0.0 to 72.0


You should set it to "72 hours" or "3 days" (without quotes).

That said, we are adding a way to control this from the UI in the next release, so you may just want to wait for a couple of days :)

PS. The dotted notation is an older one whereby the first number is the "count" and the second is the "unit". So for 72 hours you'd need to 72.6, because 0 is "none", 1 is "nanosec", 2 is "microsec", 3 is "millisec", 4 is "second", etc.

Homer712 :

May 03, 2018

Now that's perfectly clear : )

Thanks, but I think I'll wait for the UI change:
Missed Backup Alerts: On - Off

Alex Pankratov :

May 03, 2018

Missed Backup Alerts: On - Off

Yep, pretty much - https://bvckup2.com/wip/03052018

New topic

Create
Made by Pipemetrics in Switzerland
Support


Follow
Twitter
Blog / RSS
Miscellanea Press resources
Testimonials
On robocopy
Company
Imprint

Legal Terms
Privacy