The support forum

Error talking to the mail server

justbackmeup :

May 17, 2018

Since upgrading (or sometime shortly after upgrading -- I'm not sure which) to Release 79.0 my email alerts keep failing with the above error (I see the above when I try to do a test message send). It does "Logging in..." then "Sending email..." then it fails.

I've not changed anything in my settings (which previously worked), and other software I use can successfully send emails using the same provider (AOL), account and port (587). Let me know what else you need from me to troubleshoot and/or if there's anything else I should try.

Thanks!

Alex Pankratov :

May 17, 2018

There were no changes in that part of the program, so if it _is_ connected to the update, then it's due to the program as a whole changing, meaning that it's likely to be an antivirus reaction of some kind.

Look in the log - it actually logs the exact failure reason. You can also do a test email send via Backup Settings > More Options > Email Alerts > Configure > How to Send > Send Test Email and it will give you a detailed log of its conversation with you mail server.

justbackmeup :

May 17, 2018

You can also do a test email send via Backup Settings > More Options > Email Alerts > Configure > How to Send > Send Test Email and it will give you a detailed log of its conversation with you mail server.

Yeah, that's what I was referring to having done above.

But I should have thought to go looking for the detailed log file! Here's the final part of the log, showing successful authentication, followed by something failing:

235 2.7.0 Authentication successful


2018.05.16 22:39:55.957 (UTC-5) 3 Logged in
2018.05.16 22:39:55.957 (UTC-5) 3 State 15 -> 16
2018.05.16 22:39:55.957 (UTC-5) 3 <--[ tls ]--

MAIL FROM: <REDACTED@aol.com>


2018.05.16 22:39:55.957 (UTC-5) 3 (tls) <- 69
2018.05.16 22:39:55.957 (UTC-5) 3 sent
2018.05.16 22:39:55.958 (UTC-5) 3 (tls) -> 0, total 37
2018.05.16 22:39:55.958 (UTC-5) 0 Function TlsRecv() failed with 1
2018.05.16 22:39:55.958 (UTC-5) 0 recv() failed with 0
2018.05.16 22:39:55.958 (UTC-5) 3 State 16 -> 20
2018.05.16 22:39:55.958 (UTC-5) 3 Shutting down TCP ...
2018.05.16 22:39:56.037 (UTC-5) 3 (tls) discard()


I also tried disabling Norton Smart Firewall and Auto-Protect, but the result was the same. Good suggestion though to check antivirus!

Seems like something is failing with the TLS connection or something?

It's helpful to know nothing changed with the mail part of the Bvckup -- it's possible that AOL changed something on their end, but I'm not yet clear on what that might be (especially since other software is still working for some reason).

Thoughts/hunches?

Alex Pankratov :

May 17, 2018



Something is off with indeed. Bvckup 2 uses Windows' built-in SSL implementation (called "SChannel"), so perhaps something changed there with a recent Windows update... hard to say.

Can you forward me a copy of your %LocalAppData%\Bvckup2\bvckup2-smtp.log? The login information is not logged there, so if you are going to redact things out, please _replace_ them with *** (rather than deleting them).

Alex Pankratov :

May 17, 2018



After staring intently at your log, this is the relevant bit:

2018.05.16 22:39:55.958 (UTC-5) 3 (tls) -> 0, total 37


"0" here means that an attempt to receive data from the remote end yielded 0 bytes. This doesn't mean that there's no data was available, but it rather means that the connection was closed by the peer. Not that it got broken, but that the remote side explicitly closed down the connection.

Moreover, it closed the *TCP* connection and without executing an SSL shutdown first. This most likely means that something in middle (between you and AOL) is emulating the connection closure... so it's likely to be some sort of firewall or network filtering software. Again, it can be an AV.

Try this - uninstall Bvckup2 (but select to keep the config data), reboot and then install it again. This should help resetting AV's per-program state and just may clear the issue. I still think it's likely to be an AV issue.

justbackmeup :

May 17, 2018

Thanks for the intense staring! ;) I so appreciate your technical understanding (and explaining) of these things.

I'm going to try the uninstall/reboot/reinstall hopefully this evening, and will also email you the full log shortly (in case there's anything else useful in it).

justbackmeup :

May 29, 2018

Resolved in 79.2: https://bvckup2.com/support/forum/topic/1060/5974

New topic

Create
Made by Pipemetrics in Switzerland
Support

Follow
Blog / RSS
Social Twitter
Reddit
Miscellanea Press resources
Testimonials
Company
Imprint
Legal Terms
Privacy