The support forum

CreateFile() Failed with 395

bazward :

Jun 01, 2018

Using latest version of Pro for Windows 10 (v79.3)

The above started coming up this morning.

Tried several times to repeat the backup job - same result each time.  The actual body text of the error under the heading line is

2018.06.01 08:25:00.099 (UTC+0) 3 4                 Context: \\?\C:\Users\barry\OneDrive\FAB\Clients\MG Ceramics\1200 tx.xlsx 80000000 00000003 00000003 4a000000

OneDrive is running fine, the app is set as a service with elevated rights

It would be useful, primarily, if there was a list of error codes so the more technically geeked amongst us can look up the code and potentially identify the issue without having to bother the support gods.

Alex Pankratov :

Jun 01, 2018

if there was a list of error codes


Here it is, from the horse's mouth - https://msdn.microsoft.com/en-us/library/windows/desktop/ms681381(v=vs.85).aspx

However as you can see, 395 is not documented there. It's a newer error code, OneDrive-specific. It does however show up in Windows 10 SDK and it's ERROR_CLOUD_FILE_ACCESS_DENIED. So it is some sort of permission issue OR a yet another bug in OneDrive, of which it seems to be full of since Microsoft started actively revoking it few months ago.

If it's a permission issue, then it simply means that the user account under which bvckup2 is running doesn't have sufficient rights to modify target OneDrive folder. It may also mean that the program needs to run with full administrative rights (see Menu > Options > Preferences, 2nd option).

McBride :

Sep 20, 2020

Have the same issue going on. Program runs with full administrative rights and it was ok so far, just started recently. Plus I got on Error "ReadFile() failled with 381" which is not covered in the doc as well.

McBride :

Sep 20, 2020

Sorry I forgot the exact date. It started on 14 Sept

McBride :

Sep 20, 2020

So, yes that's a OneDrive issue. Moved the folder(s) with the problematic files out of the OneDrive folder and back, which solved the 395 error.

When I tried to do the same with the one file with the 381 error I got a "Provider not running" error. Opening the file in Word and closing it (with Autosave activated) solved this one and I was able to move it and do the same as with the ones before.

As handy as OneDrive can be, it can be a b*tch sometimes.

Alex Pankratov :

Sep 22, 2020

Thanks for the follow up. OneDrive is a new VSS. If it works, it works. But when it breaks, tracking down why can be a full-blown side quest.

New topic

Create
Made by IO Bureau in Switzerland
Support

Updates
Blog / RSS
Follow Twitter
Reddit
Miscellanea Press kit
Testimonials
Company Imprint

Legal Terms
Privacy