The support forum

ProcessReparsePoint troubles

ThatGuy :

Oct 06, 2018


I am running into about 11,800 errors on my backup from C:\ to an external drive. I did not see anything that quite matched up with my issue in previous posts with my google-foo.

"ProcessReparsePoint() failed with 721169"

There are quite a variety of numbers associated, a sampling: 721161, 721149, 721025, 786688, 458893, 852195, 393306

They appear to happen primarily with files in most system files,  WindowsApps, Windows.old, and Microsoft.NET

When they appear in other places, they still seem to be involving windows files such as Microsoft Office.

There are also 23 errors with CreateFile. One with "file not found" error 2 and the rest "access denied" error 5.

Bvckup2 is running as admin. Windows version 1809.

Great software, thanks. I don't use it as much as I should, but I am expecting that to change soon with a new setup.

Alex Pankratov :

Oct 06, 2018

OK, this is getting interesting.

You are the third person to report this.

First report was from September 6th, second - from yesterday. Both have the same symptoms - normal files are reported by Windows as being "reparse points" instead, seemingly at random.

In theory, reparse points are "pseudo" file system constructs that look like files or folders, but internally don’t correspond to something on a disk. They are instead emulated by a dedicated piece of software, e.g. OneDrive.

There’s a handful of reparse point types in existence, most of them are documented and they have standard format to their IDs [1].

So what happens in your case (and other two cases) is that Bvckup2 asks Windows for a list of items in a specific folder. Windows replies item by item, reporting for each of them the name, timestamps, size (for files) and attributes. If there’s a “Reparse Point” attribute, then another field in the reply contains the reparse point ID => that’s where these weird numbers that you see in the log come from.

So, to me, it looks like that there’s something on your machine that causes Windows to *erroneously* include “Reparse Point” attribute for normal files and also report some junk for the RP type field.

If you are running any 3rd party software that messes with disk/file access, that’d be my first guess for the culprit – anything from an antivirus to “fast search” to “cryptoware protectors”, etc.

Another option is that it’s Windows itself, but since you are on a mainstream release, it’s less likely.

Third option is some sort of infection with a *buggy* virus or a rootkit.


Alex Pankratov :

Oct 06, 2018

Also, the person from the Sep 6th incident was kind enough to follow-up with this:

The errors disappeared just as suddenly as they arrived - after several reboots, a major disk clean-up, disk repairs etc. After each stage I ran the backup - still there. There was a Microsoft update - which lead to serious blue screens - restarting in safe mode with networking. Then suddenly they were gone. I just marked it down as a Microsoft bug.

Since I have a fairly clean PC not running much else than [...] and [...] and Chrome - 64 bit Windows 10 and no fancy hardware and up to date drivers - there seemed no reason for the bluescreens.

Alex Pankratov :

Oct 07, 2018

In related news - Microsoft suspends the roll out of 1809 W10 update. (scroll down to Known Issues)

iancarter :

Jan 15, 2019

Regarding the ProcessReparsePoint() error message. I have the same problem, it started after I cloned my  HDD onto an SSD, then installed the SSD into my laptop. The SSD is a Kingston, and the app used to clone  is Adonis. Could this be a cause of my Reparse errors (1,272 errors) or is it coincidence?

Alex Pankratov :

Jan 15, 2019

What are the reported numerical error values exactly?

iancarter :

Jan 31, 2019

Hello Alex, sorry for the delay in answering. There are several error values, including:
852227, 852239, 721157, 721145, 852207, 852219, 721169, 721165, 852215,  721153, 721141, 393302, 852223, 262244, 327783, 262244, 262248... Of the 1,121 errors, the most common appears to be 852227.

I tried the override.inni approach with some of the above numbers, but it made no difference.

Hope you can help, regards, Ian

Alex Pankratov :

Feb 04, 2019

This should be resolved (or rather worked around) with 79.20. See, item #4.

New topic

Made by IO Bureau in Switzerland

Updates Newsletter
Blog & RSS
Follow Twitter
Miscellanea Press kit
Company Imprint

Legal Terms