The support forum

79.13.1 BUG: Elapsed stat for large files only starts counting after ~15 seconds

Deipotent :

Nov 05, 2018

Job is set to always copy files in full and when Elapsed time statistic is shown, it does not start counting until after approx. 15 seconds. Until then, it just shows "Elapsed 00:00:00".

The other stats seem to work OK.

Alex Pankratov :

Nov 05, 2018



I can't reproduce this. After 15 seconds - does it jump straight to 00:15:00 or starts from 00:01?

PS. Are you on Windows 7?
PPS. Did the UI remain responsive when Elapsed sat at all zeroes?  If I read your correctly, you were able to switch to showing %-age done and other progress views that were alive, right?

Deipotent :

Nov 05, 2018

It starts from 00:00:01.

On Windows 8.1 x64.

UI remained responsivewhen on zeroes, and I could switch to other progress views which worked fine.

Alex Pankratov :

Nov 05, 2018


Hmm. Few more questions then:

1. Is this reproducible or was it a one-time thing?
    If yes and you can get me a screeencap, that'd be phenomenal.

2. Do other progress views (i.e. %-age done) show progress?

3. Are you running the program in service mode?

Alex Pankratov :

Nov 05, 2018



4. This wouldn't happen to be a file that triggers in-run switching to shadow copying by any chance?

Deipotent :

Nov 05, 2018

1. I cannot reproduce this behaviour, but it happened for every large file during the original backup.

2. Other progress views showed progress from beginning and worked fine, and the file was actually being copied

3. Yes, Service mode.

4. Shadow copying shouldn't have been involved and it happened on every large file.

A bit more info in case it matters...
5. I got the message that the Bvckup2 license doesn't match the fingerprint and that it would stop after 1 hour (I hadn't updated the fingerprint/licence).  

6. The source drive had been converted from GPT to MBR and the disk structure seemed to have been corrupted slightly (My disk imaging tool of choice complained something was corrupt when I tried to resize a partition, although Windows read it without issue). I suppose it's possible this might have had an effect.

I guess we'll never know for sure what the problem was. I hope you didn't waste too much time on this.

On a different note - Due to the speed of Bvckup2, I often find myself using Bvckup as a sort of copy tool when I need to move lots of files/folders to a different location. Have you ever thought about creating a simple two-pane sync tool, whereby you select a source on left, dest on right and then pick the files/folders on left you want copied to right ?

It seems like you already have the needed modules to create such a tool.

It could obviously be expanded further into a fully-fledged sync/comparison tool.

Alex Pankratov :

Nov 05, 2018



OK, so here's the deal.

I got several reports about random weird issues that people saw after updating to 79.13. Issues are all of different types, but they all have in common that they happened on the first run after an update ONLY and they all are in fact, for the lack of a better word, bizarre. Also, the 79.13 doesn't include any changes that could help explaining these issues.

In your case, for example, it means that the CPU tick count as seen by the service was 15 seconds ahead of that seen by the UI. The tick count itself from RDTSC, which is an atomic CPU instruction, so I have no idea how this is even possible.

In another case the UI stopped receiving events from an engine, while the UI-to-engine direction remained operational. The whole thing is symmetrical, so it should either work or break in both directions.

So this makes me wonder if this is due to some sort of external influence, a sloppy quarantine of some sort or something similar. And I would certainly prefer to get to the bottom of this.

Re: this -

I got the message that the Bvckup2 license doesn't match the fingerprint and that it would stop after 1 hour (I hadn't updated the fingerprint/licence).  


#1 The drive corruption should be of little relevance here as the fingerprint doesn't include anything disk-related. So the fingerprint shouldn't be changing. But if it did change, this would fit the sloppy quarantine theory. If you still have bvckup2.log that covers this run, I'd very much like to have a look at it (preferably, via email).

#2 What do you run in terms of antivirus / security software? Basically, I'm wondering if there's a common denominator of an AV kind to all these weird cases.

Re: making a standalone copy tool - not a bad idea, let me think about it.

Deipotent :

Nov 05, 2018

The upgrade was from an old 74.12 version and it was running in a VMware VM on a Macbook.

#1 I'll see if I can get the log to you.

#2 No AV/AM. I run NoVirusThanks EXE Radar Pro v4.0 beta 29 and SpyShelter Firewall 11.1.

Dino :

Nov 07, 2018

Alex Pankratov wrote:

Re: making a standalone copy tool - not a bad idea, let me think about it.


That'd be nice, perhaps with file manager / command line integration? In
Total Commander you can use third party tools to copy files - you call the tool with some command line parameters (temp text file with file paths + destination panel and some options if need be), example:

Command: c:\Program Files\Bvckup 2\bvckup2-cli.exe
Parameters: Copy "%L" "%T"

Alex Pankratov :

Nov 15, 2018


@Deipotent - OK, found it.

New topic

Create
Made by Pipemetrics in Switzerland
Support

Follow
Blog / RSS
Social Twitter
Reddit
Miscellanea Press resources
Testimonials
Company
Imprint
Legal Terms
Privacy