The support forum

Beta Release 34

Alex Pankratov :

Sep 26, 2013

Major - licensing support


This release adds program licensing support, which is something that should help me bringing some order and structure to the evaluation and purchase process. As much as I'd like not to bother with silly things like this, I can't.

For all betas the licensing is optional. It doesn't make any difference if it has a license or if doesn't. There benefits to getting one though, the app will explain it.

For production releases licenses will be needed. If no license is present, the app will still function as normal, but backup jobs will be automatically disabled after every run (thus effectively precluding unattended usage of the app).

--

The license is a small text file that binds together the installation fingerprint (a mash-up of CPU model, Windows installation date/time, etc) and the license code, sealed with licensing server's signature.

The license can be retrieved either by the app itself or it can be downloaded manually from an URL that is available in the app. Alternatively, it can be requested and received over an email.

More details on how it all works is here - https://bvckup2.com/wip/20092013

Thoughts and comments are here - https://bvckup2.com/support/forum/topic/117

Issues resolved


* Fixed an issue with deleting an active real-time backup

* Fixed an issue with logging of folder creation errors

* Fixed bogus "message pending" notifications (again)

* Fixed an issue with post-backup delay function

Other changes


* Added right-click menu for an empty area of main window

* Reworked About window to show license information

Deipotent :

Sep 26, 2013

Typo's on "Bvckup Beta Notice" dialog, under "Getting the license" section - "...then downloading small text file to the Bvckup's..."
- "a" should be inserted before "small".
- delete "the" before "Bvckup's"

Alex Pankratov :

Sep 26, 2013

OK, thanks. So what's your impression of the whole thing?

Deipotent :

Sep 26, 2013

Went through webpage retrieval and it went fine. Instructions for Step 2 on the beta licence retrieval page say "2. Restart Bvckup if it's running ". You should make it clear that when running as a service, it's the service that needs to be restarted, not the GUI.

Just noticed something (seemingly unrelated to licencing) -  I just copied the .lic file to the service location, switched modes from service to program mode and GUI indicated registered. Then switched back to service mode and it still said registered. This is fine and expected.

However, the engine folder still exists in the User folder, with all the backup job folders. The switching log doesn't indicate any errors when moving it atomically from the User folder to the service folder.

After switching from service mode to program mode, the engine folder does not exist in the service folder, so it only seems to be an issue when going from program mode to service mode.

NOTE: I am using the HKLM\Software\Bvckup2 registry key to place the service folder in a different location.

Deipotent :

Sep 26, 2013

So what's your impression of the whole thing?

Well, you'll never convince me to like online activation, :) but the process is smooth enough. Ultimately, people who don't like online activation will not be convinced to like it just because it's a smooth process, but it's a benefit that it goes smoothly for those who don't mind.

Deipotent :

Sep 26, 2013

So what's your impression of the whole thing?

Just done internal activation in both modes and that was also nice and smooth.

Minor unrelated suggestion when displaying switch modes dialog - rather than selecting the current mode radio button with Apply button disabled (thereby forcing the user into another click to switch modes), select the other mode and have Apply button enabled. The main window title bar already clearly shows which mode you're in.

RussPa53 :

Sep 27, 2013

Running as a service, updated it that way from BR 33 to 34 as well. I see this in "Path to executable" in Services.msc : "C:\Program Files\Bvckup 2\bvckup2.exe" --service --service
is that 2nd --service supposed to be there?
- I also got a notice at reboot that Bvckup failed to start as a service, but it's running when I look at it in TaskManager or Services.....

Do I just need to edit that syntax above?

Alex Pankratov :

Sep 27, 2013

@RussPa53 - It shouldn't have two --service, but it doesn't hurt it either. I found the cause, the fix will be in the next release.

- I also got a notice at reboot that Bvckup failed to start as a service, but it's running when I look at it in TaskManager or Services.....


With regards to this - was it a message from Bvckup's UI or a system notice of some sort? If it was former, what did happen next and where are things at right now?

RussPa53 :

Sep 27, 2013

HI Alex - thanks for the - as always - prompt concern/response. This may be a one time thing -tho' it happened both at my home machine & my work machine - but I rebooted yet again at work, to be able to more accurately tell you what happens, and it did not occur. It was a notice from Bvckup that the service did not start successfully, with an offer to try again. When the dialog box that offered to try again notified me of a failed attempt to start the service, I closed that dialog box, and looked in Task Manager - Bvckup was there. As I said, it happened both at work and at home, both times the first time I rebooted after upgrading when running as a service.

MSLink :

Sep 28, 2013

DonĀ“t update to 34..  I get mess: An attempt to update your installation failed. - Try again or cancel..

Alex Pankratov :

Sep 28, 2013

@MSLink - I sent you an email. My guess is that it's due to the overzealous antivirus. If that's what it is, there *is* one thing that I can try and do, but I'd like to confirm that the cause first.

New topic

Create
Made by IO Bureau in Switzerland
Support

Updates
Blog / RSS
Follow Twitter
Reddit
Miscellanea Press kit
Testimonials
Company Imprint

Legal Terms
Privacy