The support forum

Error: SetFileValidData() failed with 87

matrisojati :

Oct 30, 2019

Hello,

so i started testing bvckup2 yesterday, and it seemed to be everything i wanted and it ran just fine during the night, but unfortunately today it started showing me this error

this does not happen if i change the destination folder (which is a NAS device) to some folder on the same machine

the backed up files seems to be fine, but i wonder what's causing this and why it didn't happen yesterday even tho nothing was changed

thanks for any help

Alex Pankratov :

Oct 30, 2019



Try adding the following override to the backup's config:

        conf.copying.ultra.set_valid_data  1

See https://bvckup2.com/support/forum/topic/1140 for how to do this.

Error 87 stands for "Parameter is incorrect", likely meaning that your destination device simply doesn't support this particular request type (though this is not very common - I haven't seen this before).

matrisojati :

Oct 30, 2019

Hello, thanks for the fast response... i've tried as you said, but i still get the error

weird, because it ran just fine all the way from yesterday afternoon, until today's dawn, when it started showing me this error

here's my override setting just in case and the error message:

https://i.imgur.com/vX6GnMZ.png

https://i.imgur.com/zeEOT8K.png

Alex Pankratov :

Oct 30, 2019

Did you reload the job after adding the override?

Oh, and which exact version are you on? Menu > Help > About.

matrisojati :

Oct 30, 2019

also, one thing i noticed is that it only happens when using copy in full setting, when using the delta copying option the error does not appear

sorry for the double post, can't seem to be able to edit my message

matrisojati :

Oct 30, 2019

oh we posted practically at the same time... yes, i tried reloading the job after editing the override

Alex Pankratov :

Oct 30, 2019



If you are NOT on 80.6, please update and give job another run.

Due to certain reasons the meaning of this override was flip-flopping between the releases (which is why it needs to be "1" to "disable" things). For 80.6 it should be "1".

Alex Pankratov :

Oct 30, 2019



Also, while you are at, add the following override as well -

        conf.copying.ultra.set_valid_data_end   0

This will be supported with the next maintenance release (80.7) and it's the same setting but with proper semantics. "0" is "disable", "1" is "enable". You will see 80.6 complaining that it's not a known key - that's expected and it will go away with 80.7.

matrisojati :

Oct 30, 2019

it was already on 80.6, i updated shortly before creating this topic... i tried fully closing the program and opening again, but still no luck

is there a way to confirm that my overrides are in effect?

Alex Pankratov :

Oct 30, 2019

Open settings.ini in the same folder and look at the value of that key there. It should be at 1. But if you are getting this error on 80.6, then the override is not in effect.

Alex Pankratov :

Oct 30, 2019

conf.copying.ultra.set_valid_data_end   0


Scratch that actually. We'll do a small incremental patch release (80.6.1) to address this issue. I'll post what to do once the release is out (shouldn't be long).

matrisojati :

Oct 30, 2019

indeed, override was not in effect... it is now and your answer fixed the problem, the error is no longer showing

i'm a little ashamed to admit, but the cause was a pretty dumb oversight on my part, because when i created the override.ini, the file extensions where hidden, so it was created as override.ini.txt haha (pretty new windows installation, forgot to turn it on), but it's all good now, thanks for you patience

also, i have a different doubt related to another backup job, not sure if you can help me here or should i create a new thread, but it's related to the "conf.force_update     *" override...

i have a job that i want to keep updating the backup basically in real time, but even when using that setting, with 20 seconds between copies, it will not run for several seconds, so i'm not sure if that override is correctly set up

https://i.imgur.com/fa2NsRZ.png

https://i.imgur.com/znnwQqT.png

Alex Pankratov :

Oct 30, 2019



OK, the patch release is out, so I'd prefer if you got rid of "inverse" overrides in your setup. Just not to lead to some head-scratching two months later when both will forget the context:

1. Change the override back to its normal value:
          conf.copying.ultra.set_valid_data  0
2. If you added "conf.copying.ultra.set_valid_data_end " remove it
3. Update to 80.6.1 using https://bvckup2.com/update

override.ini.txt


I'll make sure the loading code also looks for .ini.txt files. I suspect that this is not an uncommon slip.

with 20 seconds between copies


That's just a mandatory minimum pause between the backups *when the source keeps changing*. Each backup is still kicked off when Windows tells the program that something's changed in the source folder. If nothing changes => no events => the backup is not run.

If you want to force it to run every 20 seconds, unconditionally, then you will need to set it to be a periodic job with 20 sec interval.

matrisojati :

Oct 30, 2019

alright, changed it back to 0, removed that other line and updated to the new version, everything seems to be fine now, thank you very much

regarding the other problem, thanks, i see, it works when i switch to periodic job

thanks again man

matthewallsop :

Nov 01, 2019

Hi there am I getting this same error running Bvckup 2 Pro Version Release 80.6 error: SetFileValidData() failed with 8.

What do I need to do?

Alex Pankratov :

Nov 01, 2019



Download and install an update from https://bvckup2.com/update

New topic

Create
Made by IO Bureau in Switzerland
Support

Updates
Blog / RSS
Follow Twitter
Reddit
Miscellanea Press kit
Testimonials
Company Imprint

Legal Terms
Privacy