The support forum

Backup to NAS copies each file every time

Guido :

Feb 26, 2014

Hello Alex,

the first thing I have to say: Very nice, fast and intuitive program!

Here is my problem:
When I backup to my NAS (Synology DiskStation), every time a local file is modified all the files of the backup set are copied to the destination again although they are untouched. This didn't happend with Bvckup 1 (and doesn't happen when the destination is a local drive under Bvckup 2).

Maybe it has something to do with different timestamp calculation on Windows and Linux systems. When I take a look into the logfile all the source timestamps looks like <time.123> (where 123 could be any three-digit number) while the backup timestamps looks like <time.999> (and it is 999 at each file, created and modified time).

I've found a similar problem description and solution when using robocopy (see 1. Timestamp):
http://itaffinity.wordpress.com/2013/01/05/microsoft-robocopy-vs-linux-nas-robocopy-pitfalls/

So maybe you can also add an option for a 2-second-granularity (or something similar) when comparing timestamps between different operating systems. Or maybe there is an better option to solve this problem.



Thanks a lot and best Regards
Guido

Alex Pankratov :

Feb 26, 2014

Guido,

Bvckup attempts to automatically determine the timestamp granularity of source and destination file systems, separately for creation and modification timestamps. It then picks the largest value of each pair and uses it as threshold for comparing respective timestamps. The testing step proved to be quite hard to get right as there's a LOT of weird file systems that pretend to be NTFS, but in reality trim and round timestamps as their hind leg desires.

You *can* override the granularity and force it to be 2 seconds (see below), but I'd rather understand why current version of the granularity test fails in your case. Can you please email me a copy of your %LocalAppData%\Bvckup2\bvckup2-fsi.log? It contains the trace of the testing process.

Secondly, if you'd like to force the 2 second granularity, you will need to find settings.ini for a respective backup job (found in %LocalAppData%\Bvckup2\engine\backup-00xx folders), exit Bvckup, open .ini in Notepad and set

    conf.ctime_gran       20000000
    conf.mtime_gran     20000000

20000000 is expressed in 100ns intervals (so (2 x 1000 x 1000 x 10) x 100ns = 2 sec).

Alex Pankratov :

Feb 26, 2014

Ok, thanks for the log. This was something else altogether :) Support for it is coming up in Beta 62.

New topic

Create
Made by IO Bureau in Switzerland
Support

Updates
Blog / RSS
Follow Twitter
Reddit
Miscellanea Press kit
Testimonials
Company Imprint

Legal Terms
Privacy