The support forum

Forcing update of unchanged files

Aug 15, 2014

In certain cases it may be needed to re-run a backup of a file that doesn't appear to be modified, i.e. that has the same size and timestamps as it did on the last run.

As of R70 it's now possible to set up a rule to force the update of such files. This is an advanced option and it requires editing settings.ini of respective backup job as per https://bvckup2.com/support/forum/topic/933.

More specifically, forcing an update requires adding the following line to the ini (see above link for exact instructions) -

        conf.force_update      <path-pattern>

The <path-pattern> is a regular path matching string, e.g. "bar\*.foo", the same as used in manual filters in Include/Exclude part of the backup configuration. More than one conf.force_update line can be added to the setting.ini, all of them are read and observed during the run.

---

In particular, this feature can be used to force the backup of all files on every run. This is done by adding the following line to the job's config:

        conf.force_update     *

PaulK :

Jan 27, 2016

We have an odd program that doesn't update the windows timestamps in its database files as it modifies them. If they only change the bits and don't add bits, the file size stays the same and the file is ignored. I'd like to force the update while still using delta copying. When using this feature, it looks like it copies the file in full. Is there a way to force the evaluation of changes and only copy the changes?

Alex Pankratov :

Jan 27, 2016

What do you see logged for this file? Do you see "Resetting the delta state, because..." entry right beneath the "Updating file Xyz..." line?

PaulK :

Jan 28, 2016

Looks like I was mistaken. It's only copying the smaller dbf files in full. The larger ones are being handled correctly.

mtc :

Feb 23, 2016

Does conf.force_update still work in release 74.22?  I've edited the relevant backup's .ini file, and specified every possible combination of file-matching patterns (including no pattern, ie. the complete file name), and none appear to work.  The backup run thinks the source and destination files match (because they have unchanged file size and date), and does nothing.  FYI, I'm trying to specify a top-level file name (not in a folder).  And I would like to use pattern matching if possible.  

mtc :

Feb 23, 2016

Hmm.  Just went back to have another try, and I see that my added conf.force_update line wasn't present in the relevant .ini file.  This time I opened that .ini file directly, rather than via a Win7 file search.  And this time, putting in the desired file pattern did result in a forced update.

So that's a good thing!

I'm hoping the next backup run will be faster.  It rather looked like full copy was occurring rather than delta copy.  Haven't used delta copy previously for those files, so maybe it was a first-time issue.  The target files are in the multi-GB range.

Alex Pankratov :

Feb 24, 2016

Yeah, it's best to get to the settings.ini file via right-clicking on the job in app's window and selecting Open Location > Config & Logging. If you have more than one job configured, you will have multiple settings.ini on the system. And that's from Bvckup 2 alone.

New topic

Create
Made by Pipemetrics in Switzerland
Support


Follow
Twitter
Dev blog
Miscellanea Press resources
Testimonials
On robocopy
Company
Imprint

Legal Terms
Privacy