The support forum

Network logon failure accessing destination

Aemony :

Jul 28, 2015

Hi,

Weird issue I'm having. This is a living thread as I'll also post a new post or two after I've written this one and tried with various troubleshooting steps on my own.

Anyway, it seems that my backups stopped working and I'm not quite sure when or why... I previously had an issue that was discussed and solved in a previous thread[1], which might or might not have something to do with it.

I'm running Bvckup 2 as a background service with the destination being on various shares that reside on a NAS. Bvckup is always authenticating with the configured account (conf.dst_net_login 2). The account is the same for all the configured jobs and the same one as I use when I connect to the shares through Explorer.

I haven't checked Bvckup for a couple of weeks but when opening it today I was met by an error message that said something in the line of: "Destination folder does not exist." The error message was the same for each of the jobs. I confirmed through Explorer that I could access the network shares in question.

Updating Bvckup to 74.12 for some reason changed the error message to a new one: "WNetAddConnection2() failed with 1312". This is when Bvckup is still running as a service.

Switching mode to regular program and rerunning the jobs gives me the following error message: "specified location has an active connection under a different user name"; with an attached warning that the behavior is an inherent limitation of Windows networking and accessing a server or shared resources using more than one user name.

The problem is that Bvckup is configured to use the same account on the NAS as I use when connecting. Anonymous access is denied and there's no other account to speak of. Switching mode back to background service just gives me the WNetAddConnection error message again.

So to summarize: [2]
**General error message (both versions)**
Network logon failure accessing destination
**Error message pre-74.12 (unsure what exact version, latest one in July)**
Background service: "Destination folder does not exist" or something similar
Regular program: Didn't try this before I updated Bvckup.
**Error messages 74.12**
Background service: "WNetAddConnection2() failed with 1312"
Regular program: "specified location has an active connection under a different user name"

[1] https://bvckup2.com/support/forum/topic/608
[2] http://i.imgur.com/FrjP5wk.png

Gonna reboot and try again now.

Aemony :

Jul 28, 2015

OS: 8.1 fully updated (forgot to mention that ^^ )

Okay, so just rebooted (with Bvckup in service mode). First attempt to run the job when Bvckup was running in service mode failed with the same "WNetAddConnection2() failed with 1312" error. However switching mode to regular program and rerunning the job and it went through successfully!?

Switching back to background service and the same job failed again, same error message as before...

The background service logs on as the standard "Local System" account. My personal account that the program is running when in regular mode is a standard Admin account. Bvckup doesn't prompt for an elevation through UAC when in regular mode (only when switching between the two modes).

Aemony :

Jul 28, 2015

Eh, this is weird... So I jumped on the NAS, saw that the anonymous guest access still were active and had read access. Disabled that on all shares. Reconfigured the NAS to use SMB 3 instead of SMB 2. Rebooted the NAS.

While the NAS was rebooting I flushed the DNS and cleared the Credentials Manager of the NAS account on the computer and restarted that one as well.

After the reboot and before any connection what so ever was made to the shares I started Bvckup (service mode) and reran the jobs. Every single one passed without any errors. After those managed to pass I also opened up the shares in Explorer and logged in with the same account as Bvckup uses. Accessing the shares here worked as well. So far everything works as expected.

Switched mode in Bvckup to regular program and all of a sudden I'm met with the "specified location has an active connection under a different user name" error again! Switching back to service works fine.

I don't understand that error at all. Bvckup can access the shares when running as a service (Local System) and authenticating to the shares using the Kenny account. While Bvckup can do this, I can in Explorer (running as my local admin account) also access the shares using that same Kenny account. However when Bvckup is running as a regular program on my local admin account it can't access the shares? While I'm able to access them in Explorer as usual?

Networking is hard... *slams head in desk*

Aemony :

Jul 28, 2015

Rebooted again and launched Bvckup as a regular program and reran the jobs. They successfully passed with flying colors!

However when switching to background service I stumbled upon a weird issue. First few jobs failed ("specified location has an active connection under a different user name"), then all of a sudden a job failed with another error ("Destination device could not be found") followed by the next job completing with no errors at all. Reran all the jobs and all of them now passed...

Switched to regular program and all jobs passed again. Switched to service and now they all passed, once more. Accessed the drive through Explorer with no errors there either... Switched back a couple of times and no errors at all... I haven't changed a thing anywhere in the previous two reboots of Windows beyond in what mode I ran the jobs in Bvckup the first time after the computer had started!

Networking is even harder... *slams head in desk twice*

Aemony :

Jul 28, 2015

Final post: rebooted once more with Bvckup as a servce, reran the jobs with no errors... Tried the previous tests back and forth and no errors at all now.

I have no idea what fixed the issue and why it suddenly wants to work again in both modes! :S

Alex Pankratov :

Jul 29, 2015

For what it's worth 1312 is "A specified log-on session does not exist. It may already have been terminated", Makes very little sense for a request that carries a username/password, but then Windows networking can indeed be a black box of spaghetti sometimes.

McBride :

Sep 28, 2016

So I see, same issue... oh boy

galileo :

Sep 29, 2016

While I haven't teased enough to verify for certain...I have also seen these issues crop up randomly or at least what seems to be randomly.  

The occurrences seems to arise after resuming from "sleep" (i.e. waking rather than booting).  I run bvckup2 daily and have a task that is scheduled to wake the computer 5 minutes before the scheduled bvckup2 run time.  Typically, the wake up and backup run very consistently...but, very randomly, bvckup2 will generate an error indicating that the backup device is not available/accessible.  

I am running bvckup2 to a QNAP NAS over Gb Ethernet in application (not service) mode with bvckup2 set to wait for 5 minutes after boot/wake.  Nonetheless, there are very random and infrequent NAS access issues.  In my case these do not seem to be directly attributable to user/account authentication but rather device availability...I think...

Also worth mentioning - my QNAP NAS is set to power down after 30 minutes of inactivity, which means that generally it will also need to wake up itself.  Hence, my wake up task wakes the computer and pings the NAS 5 minutes prior the bvckup2 scheduled run in order to force an NAS wake up.

Generally, this is a very reliable and consistent protocol....but, as noted, there is that very random strange bird device unavailable issue.  I have resolved to just "live with it" for now...at least until Alex works some future magic!  Fortunately, I am dealing with a home/personal installation.  In a business (mission critical) environment, I would likely be rather more anal about getting an immediate solution.

I doubt my comments help...but, they may add another data point at least...

McBride :

Sep 30, 2016

Seems we have a similar situation. But with my old backup product I did not have the wake up issue. That's new to me. Maybe there can be done something about it, programmatically. Idle drives on a NAS do not seem to be an unlikely scenario to me.

Alex Pankratov :

Sep 30, 2016

Idle drives on a NAS do not seem to be an unlikely scenario to me.


They can actually be. If NAS keeps its internal logs on these drives and it's dumb about writing them, then if it logs something upon receiving a connection request, then it may end up *not* responding to this request until disks spun up and the log entry is written out.

What I can do is add a basic retry mechanism for the logon attempts. Should have it done and out before the end of today. Let's agree to treat it as an experimental feature, so don't expect much from it.

galileo :

Sep 30, 2016

Alex - a thought along those lines:  an option for some "number" of chosen logon retry attempts at some "intervals" of time before bvckup2 errors out - e.g.  Number of logon attempts = x   and   Retry time interval = y minutes

...perhaps something akin to that...

Alex Pankratov :

Sep 30, 2016

Yep, I did it *precisely* like that.

Except for the "minutes" part, it can understand other time units, not just minutes.

McBride :

Sep 30, 2016

Sounds like a plan.

Plus, guys let me make one thing clear: I never in my entire 30 years of IT work had this awesome quality of support, ever!

Alex Pankratov :

Oct 03, 2016

Ok, the update's out. Please give it a try, gentlemen, and let me know if paced retrying works. If it does, then I can tweaks the defaults for others' benefit.

https://bvckup2.com/support/forum/topic/797/4543

New topic

Create
Made by IO Bureau in Switzerland
Support

Updates
Blog / RSS
Follow Twitter
Reddit
Miscellanea Press kit
Testimonials
Company Imprint

Legal Terms
Privacy