The support forum

Pre-run command problem

brighthero :

Jan 30, 2016

So I have to solve 2 problems:
1. Is there any way to run the pre backup command even if the destination device is not connected? The command would then mount the drive.
2. The drive would be mounted with VeraCrypt as a removeable device. The problem here: Running something like "cmd start /D "c:\Program Files\VeraCrypt" veracrypt" doesn't seem to be working, it just keeps saying "running external command".

Any ideas why this is happening?

Alex Pankratov :

Feb 01, 2016

1.

Yes, doable, but you will need to disable destination device monitoring for the backup job. By default, the app won't run a backup until both source and destination devices are present. So if you want to run a job when one of them is missing, you will need to suppress this monitoring.

This is done by changing "conf.dst_force_present" entry in the backup's settings.ini from 0 to 1. With newer versions it will be "conf.wait_for_dst" and it will need to be flipped from 1 to 0.

Right-click on the backup job in main window, select Open Location > Config & Logging, exit the app, open settings.ini in Notepad, make the change, save & exit, start the app again.

Feature thread - https://bvckup2.com/support/forum/topic/502/2960

2.

That's between you and VeraCrypt, sorry. I can however tell you that the above feature was introduced to address your *exact* scenario - someone too needed to mount a VC (or TC) drive before running the backup - so what you are after is doable. I just don't know the details.

brighthero :

Feb 01, 2016

Thanks so much!

But my pre-backup command is still not working. In fact putting the command in a .bat-file is totally working for me!
I also tried running just the .bat and some other "dummy" commands but the backup just stops and says "running external command"

log:
2016.02.01 19:22:35.602 (UTC-1) 3 2 Copying: contents, timestamps (modified and created), attributes
2016.02.01 19:22:35.602 (UTC-1) 2 2 Running external pre-backup command ...
2016.02.01 19:22:35.602 (UTC-1) 3 3 Command: cmd /k "D:\veraLightroomMount.bat"
2016.02.01 19:22:35.602 (UTC-1) 3 4 Critical: no
2016.02.01 19:22:35.602 (UTC-1) 3 4 Timeout: 1 hour

nothing happens for one hour. I feel like I am doing something very wrong here...

Alex Pankratov :

Feb 04, 2016

Are you running in the service mode by any chance?

"cmd /k" means "execute command and keep the window open". Perhaps you meant "cmd /c" instead?

In any case, you can try and set D:\veraLightroomMount.bat as pre-command. No qoutes, nothing, just

     D:\veraLightroomMount.bat

The app will notice that the command ends with .bat and it will launch it through shell (Windows Explorer) rather than through the low-level CreateProcess facility.

brighthero :

Feb 05, 2016

Yep, that was it! Thank you so much for your help!

New topic

Create
Made by IO Bureau in Switzerland
Support

Updates
Blog / RSS
Follow Twitter
Reddit
Miscellanea Press kit
Testimonials
Company Imprint

Legal Terms
Privacy