The support forum

Quiet times / Scheduled Hours

Aug 29, 2017

Starting with Release 78 it's possible to suppress scheduled and real-time backups in certain time/day periods - a feature referred to as "quiet times" or "quiet periods".

Overview


Quiet times (QT) are configured on per-backup basis. It's possible to have more than one QT specified for a backup job.

When a job enters a quiet period, the backup engine will not schedule any backup runs until the period is over. If a backup is running when a quiet period starts, it will continue running as usual, to completion.

A job in a quiet period can still be run manually at any time.

Each QT entry comprises the starting date/time and duration. It may also have a "repeat" attribute, which will do what it implies - repeat the QT as specified.

It is also possible to specify a day of the week as the QT's starting point. This is meant to support a very common case of mandatory weekly blackouts.

Aug 29, 2017

Configuring quiet periods


Configuring quiet periods for a job is done by manually adding period definition to the job's configuration file.

        See this topic for how to apply a configuration override -
        https://bvckup2.com/support/forum/topic/1140

Each quiet period is described by its own "conf.quiet_time" line, e.g.

        conf.quiet_time    2017-08-29 12:34, 3 hours

This defines a 3 hour quiet period starting at specified date and time.

        conf.quiet_time    2017-08-29 12:34,  3 hours, 12 hours

Same, but the period is then repeated every 12 hours.

Note #1 - the "start" point can be set into the future. This can be useful for scheduling one-off quiet periods around one-off external events.

Note #2 - the "repeat" interval must not be shorter than the QT "duration," e.g. something like this is a configuration error and it will cause the job to be disabled on load:

        conf.quiet_time    2017-08-29 12:34, 10 hours, 2 hours

Aug 29, 2017

Weekly scheduling


Simplified notation can be used to schedule weekly quiet periods:

        conf.quiet_time    Monday 12:34, 10 hours

A day of the week followed by HH:MM, comma, followed by duration.

It's also possible to specify the repeat interval, but it must be a multiple of one week. E.g.

        conf.quiet_time    Monday 12:34, 10 hours, 3 weeks
        conf.quiet_time    Monday 12:34, 10 hours, 14 days

are both acceptable, but

        conf.quiet_time    Monday 12:34, 10 hours, 3 days

is not and it will yield a configuration error on job's load.

Dialp :

Sep 15, 2017

Thanks, Alex! I was really looking forward for this feature.

I've just configured my backups to skip the weekends, let's see how it works out!

kostas.michas :

Sep 29, 2017

Hi guys,

When will that be ready on the user interface please?

Cheers!

Alex Pankratov :

Sep 29, 2017

Most likely in a couple of major releases - in R80 or thereabouts.

kostas.michas :

Oct 30, 2017

Ok thank you Alex

roadrunnerm :

Feb 01, 2019

This is not working very well

I use https://bvckup2.com/support/forum/topic/971 and https://bvckup2.com/support/forum/topic/1140

I have make a override.ini file
conf.src_eject_device   1 (after this i goto next line) this was working whitout a error but it hold not any conf.quiet_time configuration

First i put this line in it override.ini file
conf.quiet_time    2019-02-02 9:00,  16 hours, 11 hours (after this i goto next line) and save the file
Reload the backup job whit the crtl key holding
I get a error Configuration file is invalide

Second I Edit the override.ini file and put the following 2 lines in it.
conf.src_eject_device   1 (after this i goto next line)
conf.quiet_time    2019-02-02 9:00,  16 hours, 11 hours  (after this i goto next line) and save the file
Reload the backup job whit the crtl key holding
I get a error Configuration file is invalide

best regards,
Martin

Alex Pankratov :

Feb 01, 2019



This is because of this -

Invalid ini entry [conf.quiet_time] -> [2019-02-02 9:00,  16 hours, 11 hours], line 2 -- "Repeat" interval is shorter than "Duration". The job will remain in a quiet state forever.


I.e. you have a 16 hour quiet period repeating every 11 hours.

That said, this should not cause the job reload to fail. It is merely supposed to disable the job and add the above message to its log. I'll see that we get this fixed asap.

[Edit] ... and this message *is* actually logged, but the UI doesn't pick up on this fact and show it in the log panel.

albspe :

May 04, 2019

Is it possible to have quite times between 7pm to 9am only during the week days? I was able to configure the first (works), I think I understand how to have weekdays being quite times, but combine the two, not sure I see how to do that ... suggestion? Thx!

albspe :

May 04, 2019

sorry meant to say "I think I understand how to have *weekends* being quiet times"

Alex Pankratov :

May 04, 2019


quite times between 7pm to 9am only during the week days


conf.quiet_time    Mon 19:00, 14 hours
conf.quiet_time    Tue 19:00, 14 hours
conf.quiet_time    Wed 19:00, 14 hours
conf.quiet_time    Thu 19:00, 14 hours
conf.quiet_time    Fri 19:00, 14 hours

If you want to add weekends there too, just add:

conf.quiet_time    Sat 00:00, 24 hours
conf.quiet_time    Sun 00:00, 24 hours

albspe :

May 05, 2019

thx, great!

New topic

Create
Made by IO Bureau in Switzerland
Support

Updates
Blog / RSS
Follow Twitter
Reddit
Miscellanea Press kit
Testimonials
Company Imprint

Legal Terms
Privacy